
Pathway Studio Quick Start Guide

This Quick Start Guide is for users of the Pathway Studio 4.0 pathway anal-
ysis software. The Quick Start Guide demonstrates the key features of the soft-
ware and provides the information on how to optimize its use.

For the hardware and software requirements, installation instructions,
and the information on how to activate Pathway Studio 4.0, re-
fer to the Installation Guide available from the Ariadne’s web site
(http://www.ariadnegenomics.com).1

h This Quick Start Guide demonstrates how to:

; Launch Pathway Studio, refer to Section 1.1
; Install and open a local database, see Sections 1.2 and 1.3
; Open and inspect a pathway, refer to Sections 1.4 and 1.5
; Print a pathway diagram, or save it as a clicable HTML file, refer to

Section 1.6
; Search a database, see Section 1.7
; Import a list of genes from your experiment into a local database, see

Section 1.8
; Build and edit pathways using the Pathway Wizard, see Sections 1.9,

1.10, 1.11, and 1.12
; Manage groups, see Section 1.13
; Analysis of expression data, refer to Section 1.15
; To access the technical support service, see Sections 1.16 and 1.17

1.1 Launching Pathway Studio

To launch the software, double-click the Pathway Studio icon on
your Desktop, or in the folder where the software has been installed.
The first time you start the software after the installation, the Quick
Start Guide appears. We recommend following the Guide to take you
through the initial steps of using Pathway Studio. To launch the

Pathway Studio iconPathway Studio User Manual, click Help>Manual on the menu bar.
To exit Pathway Studio, save your data, then choose the Database
>Exit menu.

1 http://www.ariadnegenomics.com/downloads/?page=pathway\&group=
downloads#groups

1

http://www.ariadnegenomics.com/downloads/?page=pathway&group=downloads#groups
http://www.ariadnegenomics.com/downloads/?page=pathway&group=downloads#groups
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Make sure that you install the software under the Administrator ac-n
count.

Pathway Studio first appears on the screen with the blank Pathway
Pane and Database Pane. After you download and open a database, the
Database Pane will show the database contents. Refer to Figure 1.1.1.
Proceed to Section 1.2.

Figure 1.1.1: The Database Pane shows the content of the ResNet Core
database. ResNet Core is a unique database containing manually curated phys-
ical interactions, as well as the most reliable set of relations for mammal pro-
teins; it also includes a collection of more than 1,000 manually curated and
automatically reconstructed signaling pathways.
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1.2 Installing a Local Database

To start working, you need a database. You can copy the ResNet
Core database from your installation disk. ResNet Core is a subset of
ResNet 4.0 database and comes as a part of the Pathway Studio soft-
ware. See Figure 1.1.1. You can use ResNet Core as your first database;
or you can download the ResNet database from the Ariadne’s web site.2 Make sure your hard

drive is large enough:
Pathway Studio
databases may take up to
2 GB of disk space.

To download the last version of the ResNet 3.0 database (or any other
Ariadne’s database) from the web site, select the Database>Download
Database menu. In the Download and Open Database dialog box that
appears, choose the Download Database from the Internet option. See
Figure 1.2.1. Select the ResNet 3.0 database from the list and press OK.
The last available version of the ResNet database will be downloaded
to your computer. Proceed to Section 1.3.3 Refer to Section 1.17.

Figure 1.2.1: The Download and Open Database dialog box.

2 http://www.ariadnegenomics.com/downloads/?page=resnet
3 http://www.ariadnegenomics.com/

http://www.ariadnegenomics.com/downloads/?page=resnet
http://www.ariadnegenomics.com/
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1.3 Open a Database

h To open a database:

; Select the Database>Manage Databases>Open Local Database menu;Menu:
Database>

Manage Databases>
Open Local Database

; In the Open Local Database dialog box that appears, select a database
from the list and press Open. The Ariadne’s database files have
*.gpc extension;

; The next time you start Pathway Studio, the last opened database
opens automatically.

1.4 Viewing Pathways

The ResNet Core database comes preloaded with a collection of more
than 1,000 manually curated and automatically reconstructed signaling
pathways. As an example, open and inspect the "Apoptosis" pathway.

; Open the Curated Pathways folder in the Database Pane and double-
click on the Apoptosis pathway;

; The pathway view appears in the Graph View of the Pathway Pane.
For the shapes and colors of pathway entities refer to Section 1.5. See
Figure 1.4.1;

; View or update the pathway. Use the Pathway Pane Toolbar to trans-
form the pathway map. For example, you can apply the Clone Entities
and Fit Text to Entities options to make the pathway diagram view
clearer; or you can use the Zoom by Rectangle, or Magnifier option to
zoom-in on parts of the pathway;

; Use images from the Images Pane, as well as Coloring and Alignment
options to edit the pathway view;

; Use the Dynamic Layout option to layout the pathway by cell localiza-
tion. For more options, refer to the Pathway Studio User Manual,
Chapter 16, Pathway Layout and Manual Curation;

; To view the list of pathway entities, open the Entities tab. To view the
list of pathway relations, open the Relations tab;

; To save the pathway, select the Pathway > Save Pathway menu. To
save the pathway under a different name, select Pathway > Save
Pathway As. The pathway will be saved in the Pathways folder in
your account.
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Figure 1.4.1: The Apoptosis pathway.

1.5 Shapes and Colors of Pathway Entities

The Palette Pane summarizes shapes and colors assigned to different
pathway entities. To open the Palette Pane, click the Palette tab. See
Figure 1.5.1.

The Images Pane contains a set of images of the cell organelles that can
be included into a pathway diagram. To open the Images Pane, click the
Images tab. Note that you can add your own images (*.GIF, *.BMP, *.JPG,
and *.PNG files) in the Images Pane and use them in your pathways. See
Figure 1.5.1.

Visual presentation of pathways can be also adjusted by changing the
color, the shape, and size of the entities, as well as enabling high quality
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Figure 1.5.1: The Palette Pane and the Images Pane.

graphic and defining the color of links. Refer to the Pathway Studio
User Manual, Chapter 17, Display Styles for Pathway Representation.

1.6 Printing Pathway Diagrams

You can print or save a pathway diagram as a picture directly from the
software:We recommend that you

preview a graph image of
a pathway before

printing.
; Prepare Page Setup by selecting Pathway>Page Setup. The Page Setup

dialog box appears. Choose the paper size, choose the printer, and
press OK to print;
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; Choose Pathway>Print Preview, the graph image of the pathway ap-
pears in the preview window. Make sure that everything is all right
with the image. Then, press Print to print the picture. See Figure 1.6.1.

Figure 1.6.1: The Page Setup, Print Preview, and Print options are available via
the Pathway menu.

h To save a pathway diagram as a clickable HTML file:

; Open a pathway of interest;
; Select Edit>Save Pathway as HTML;
; Select the destination catalog for your HTML file;
; Press the Save button;
; The HTML file and the catalog with the same name as your pathway

appear in the chosen location;
; Open the HTML file to see the pathway in the Internet Explorer

browser.

To include a pathway picture into a manuscript file for publication, we
recommend that you enlarge the pathway map as much as possible and
save the pathway image in TIFF format. For more information, refer to
the Pathway Studio User Manual, Section 20.4, High Resolution Path-
ways Images.
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1.7 Quick Search

The Quick Search box is located at the top of the Database Pane. Your
search results will be listed in the List Pane. You can drag and drop rows
from the List Pane to your active pathway, or save the search results as
an individual group in the Groups folder.

Figure 1.7.1: The Quick Search box.

1.8 Importing Lists of Genes or Proteins

To import a list of genes or proteins, select Tools>Import Protein List.
In the Import Protein List dialog box, paste the list of proteins through
the Clipboard; or use the Load from File option to upload the list from
a file. The descriptions will appear for those proteins that are succes-
sfully mapped in your database. The proteins that were not found will
be shown as not found in the description. Press Import. The List Pane
opens and the list of proteins appears as a new group.

Refer to the Pathway Studio User Manual Chapter 12, Importing of Pro-
tein IDs to learn more about Importing of Protein Lists. See Figure 1.8.1.
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Figure 1.8.1: The Import Protein List dialog box.
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1.9 Pathway Wizard

Pathway Wizard allows you to create pathways using molecular interac-
tion data from the database. It starts by suggesting several ways to de-
termine starting entities, and then opens the Build Pathway dialog box.
See Figure 1.9.1.

Figure 1.9.1: The Pathway Wizard button is located on the Database Pane
Toolbar.

h To use the Pathway Wizard:

; Click on the Pathway Wizard button on the Database Pane toolbar;Or select the Database
>Pathway Wizard menu. ; Type in the pathway name. See Figure 1.9.1;

; Find entities to start building your pathway: you can use Search by
String, Search by Attributes, or Import a Protein (Gene) List options;

; Click Next. The Build Pathway dialog box appears. See Figure 1.9.2.

h In the Build Pathway dialog box:

; Check starting entities for your pathway, see (1);
; Choose an algorithm for pathway building, see (2);
; Check the Filter option and set up the filter, if needed, see (3);
; Press the Start button to start data mining, and then click OK when

done (4). The new pathway diagram appears in the Pathway Pane.
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Figure 1.9.2: The Build Pathway dialog box.

Refer to the Pathway Studio User Manual Chapter 13, Build Pathway
Tool to learn more. See also Tutorial, How to Use Build Pathway Filter
Options to Solve Bioinformatics Problems available for download from the
Download Center.4

4 http://www.ariadnegenomics.com/downloads/?page=pathway\&group=
tutorials#Filter

http://www.ariadnegenomics.com/downloads/?page=pathway&group=tutorials#Filter
http://www.ariadnegenomics.com/downloads/?page=pathway&group=tutorials#Filter
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1.10 Creating New Pathways

h To create a new pathway, select the Database>New Pathway menu,
or click on the Create Pathway button. The Palette Pane opens, and an
empty pathway appears in the Pathway Pane and in the Database Pane.

1.11 Saving Pathways

; To save a pathway, choose Pathway>Save Pathway;
; To save pathway as a picture, choose Edit>Save Picture As;
; To save pathway as HTML, choose Edit>Save Pathway as HTML.

1.12 Adding Entities and Relations to Pathways

Figure 1.12.1: The Expression relation has been added to the pathway.

To add entities to a pathway, drag and drop them from the Palette Pane,
or use the Quick Search option, see Section 1.7. To add a new relation,
select two entities that should be connected, and press the Connect Se-
lected Entities button on the Toolbar. Refer to Figure 1.12.1.
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1.13 Working with Functional Groups

You can create groups from your imported gene or protein lists, or from
other objects, and highlight objects belonging to various groups on your
pathway diagrams. You can work with grouped objects in the Pathway
Pane, as if they were a single object. Objects in a group cannot be se-
lected individually, unless you open the group. See Figure 1.13.1.

Figure 1.13.1: Components belonging to the Drugs group are highlighted on
the opened pathway diagram.

h To create a functional group:

; Select entities you would like to group together. You can select them
manually, or using the tools provided by the Select menu;

; Click the Create Group button on the Database Pane toolbar, or right
click and choose Create Group from the popup menu;
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; The new group folder appears in the Database Pane. Right click on
the new group, and choose Properties from the popup menu;

; Specify the group name, properties, and highlight color in the Group
Properties dialog box. See Figure 1.13.1.

; To highlight items belonging to a group on an active pathway, right
click on the group folder, and select the Highlight menu.

1.14 Complex Entities

You can also add or delete components from the following complex enti-
ties: Functional Class, Complex, and Pathway. To open any of these entities
in the List Pane, right click on the entity, and choose the Open in Sepa-
rate Window menu.

1.15 Analysis of Microarray Data

Following is the list of functionality available for analysis of expression
data in Pathway Studio:

; You can import expression matrix data using the Generic format op-
tion of the Expression>Import Expression Experiment menu. Refer
to Section 24.1 of the PathwayStudio User Manual.

; You can import Affymetrix CEL files using the Expression>Import Ex-
pression Experiment> Affimetrix Format (CEL) option. Refer to Sec-
tion 24.10 of the PathwayStudio User Manual.

; You can import GE GenePix files using the Expression>Import Ex-
pression Experiment> GenePix Format (GPR) option. Refer to Section
24.11 of the PathwayStudio User Manual.

; You can sort and filter imported expression data by expression values
and by p-values. Refer to Section 27.11 of the PathwayStudio User
Manual.

; You can find differentially expressed genes using the Expression
Significance algorithm. Refer to Sections 25.1 and 25.2 of the
PathwayStudio User Manual.

; You can perform gene clustering using the Pearson Correlation algo-
rithm. Refer to Sections 26.1 and 26.2 of the PathwayStudio User
Manual.

; You can find major regulators among differentially expressed genes
using the Find Direct Interactions option of the Build Pathway tool.
Refer to Chapter 14 and Section 27.6 of the PathwayStudio User
Manual.
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; You can find upstream regulators for gene clusters or differentially
expressed genes using the Find Common Regulators option of the
Build Pathway tool. Refer to Chapter 14 and Section 27.6 of the
PathwayStudio User Manual.

; You can find pathways or groups containing differentially expressed
genes using the Find Pathways or Find Groups algorithm. Please, note
that in order to maximize the results of the Find Groups algorithm,
you have to import Gene Ontology groups using the Import Wizard.
Refer to Sections 21.1, 21.7, and 27.7 of the PathwayStudio User
Manual.

; You can find biological processes affected by the differentially ex-
pressed genes using the Find Common Targets option with the fil-
ter set to Cell Process only. Refer to the Tutorials: How to Find Com-
pounds Regulating Transcription Factors in the Pathway Studio Database
and Biomarkers Discovery and Validation in the ResNet Database. These
tutorials are available for download from the Ariadne’s web site.5

The software is shipped with a set of expression experiment samples
stored in the Expression Favorites folder. By default, new expression
experiments will be automatically saved to this folder. h As a start-
ing point, open the Expression Favorites folder and double click on the
"Log(generic chip format)" sample. The Import Expression Wizard ap-
pears. Follow the steps provided by the import routine. In the Choose The wizard appears

automatically for those
experiments that have
never been opened
before.

Column with Gene IDs and Define the IDs Type dialog box, set the op-
tions as shown in Figure 1.15.1 below.

Figure 1.15.1: In the Column with Gene ID listbox, select LocusLink ID; in the
Type of Gene ID listbox, select LocusLink ID. Press Next and follow the steps
provided by the Import Wizard.

5 http://www.ariadnegenomics.com/downloads/

http://www.ariadnegenomics.com/downloads/
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After the import is done, the Expression Viewer pane opens automati-
cally and shows you the expression experiment as a heat map.

h To overlay the expression experiment onto a pathway diagram:

; Open a pathway of interest. As an example open the "4-1BB ligand"
pathway from the Curated Pathways folder;

; Make sure that the Color By Expression option is turned on;
; Select the Expression> Color Entities by Expression menu or click

the Enable Coloring by Expression Values button on the Expression
Viewer toolbar;

; Pathway entities will be colored according to their expression values;
; To display only genes that are presented in the current pathway, click

the corresponding button on the Expression Viewer toolbar;
Display Genes

Present in the Current
Pathway Only

; In the Expression Viewer, click on the sample you want to visualize
on the active Graph View. See Figure 1.15.2.

Figure 1.15.2: Pathway entities are colored according to their expression val-
ues.

h To build a new pathway from the expression experiment:

; Open the "Log(generic chip format)" experiment;
; Select genes by clicking on them while holding down the ctrl key;
; Use the Group Selected Genes Together context menu to put all your

genes of interest at the top of the Expression Viewer window;
; Press the Build Pathway from Selected Genes button located on the
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Expression Viewer Toolbar. Refer to Figure 1.15.3;
; In the Build Pathway dialog box, set up the pathway building param-

eters. Press Start. Press OK to view the pathway;
; The new pathway appears in the Graph View window. On the path-

way map, the entities are colored by expression values. See also Tu-
torial Working with Gene Expression Data: the Expression Viewer available
for download from the Ariadne’s web site.6

Figure 1.15.3: The new pathway is open in Graph View window. Pathway
entities are colored by expression values.

h To create a new group from the expression experiment, follow these
similar steps:

; Open the expression experiment and select genes; Menu:
Expression>
Create Group
from Selection

; Press the Create New Group Toolbar button;
; Enter the group name in the dialog box;
; Check the box Open New Group when Dialog Closed;
; Press Create Group button, and then press Close;
; A new group appears in the Database Pane.

6 http://www.ariadnegenomics.com/downloads/?page=pathway\&group=
downloads#groups

http://www.ariadnegenomics.com/downloads/?page=pathway&group=downloads#groups
http://www.ariadnegenomics.com/downloads/?page=pathway&group=downloads#groups
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1.16 Sales and Technical Support

If you are a licensed user of Pathway Studio, you may contact techni-
cal support via the web site or call (240) 453-6301.7

h To purchase Pathway Studio, schedule the software demonstra-
tion, or inquire about pricing:

; Phone: (303) 838-4268
; Toll Free: (866) 340-5040

1.17 Troubleshooting

Pathway Studio is the most popular software package for pathway
analysis in the world. In very rare cases our new customers experience
problems with installation and running the software.

; The errors can occur if your computer does not meet hardware re-
quirements described in the Pathway Studio Installation Guide.8

; Please, note that Pathway Studio will run only on the MS Win-
dows 2000, MS Windows XP Professional, or MS Windows 2003 Server
operating system. Ensure that your OS is updated. Please, visit the
Microsoft web site and download all critical and recommended up-
dates.9 Make sure that you install the software under the Adminis-
trator account.

; Make sure that your MDAC version is 2.6 or higher. To check the MDAC
version, please, go to the Microsoft web site.10

; When re-installing Pathway Studio, make sure to uninstall it, first,
using Control Panel, and then reinstall.

; In case of corruption of the ResNet database during download, use
Internet Explorer to download the database from the Ariadne’s web
site, then unzip it, and open with Pathway Studio.11

7 http://www.ariadnegenomics.com/products/support.html
8 http://www.ariadnegenomics.com/downloads/?page=pathway\&group=
downloads#groups

9 http://support.microsoft.com/
10 http://support.microsoft.com/default.aspx?scid=kb;en-us;301202#3
11 http://www.ariadnegenomics.com/downloads/?page=resnet

http://www.ariadnegenomics.com/products/support.html
http://www.ariadnegenomics.com/downloads/?page=pathway&group=downloads#groups
http://www.ariadnegenomics.com/downloads/?page=pathway&group=downloads#groups
http://support.microsoft.com/
http://support.microsoft.com/default.aspx?scid=kb;en-us;301202#3
http://www.ariadnegenomics.com/downloads/?page=resnet
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